AutoDirectionTypeEnum Enumeration

The auto direction type defines how a connection or detail coordinate system will be oriented automatically.

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public enum AutoDirectionTypeEnum
Members
  Member nameValueDescription
AUTODIR_NA0 The auto direction will not be available.
AUTODIR_BASIC1 The auto direction type for usual joints will be used.
AUTODIR_DIAGONAL2 The auto direction type for diagonal joints will be used.
AUTODIR_SPLICE3 The auto direction type for splices will be used.
AUTODIR_DETAIL4 The auto direction type for details will be used.
AUTODIR_GLOBAL_Z5 The auto direction type with joint direction at the global Z will be used.
AUTODIR_SEATING6 The auto direction type for seating joints will be used.
AUTODIR_PRIMARY_X7 The auto direction type with joint direction parallel to the primary X-axis will be used.
AUTODIR_FROM_ATTRIBUTE_FILE99 The auto direction type is fetched from the loaded attribute file.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next