AutoDirectionTypeAttribute Class |
The AutoDirectionTypeAttribute class is used for storing the auto direction type.
Based on the type the system will then calculate the up direction of the connection/detail
if the "Auto" up direction is chosen in the dialog.
The attribute is initialized from the custom attribute
[AutoDirectionType(AutoDirectionTypeEnum.AUTODIR_DETAIL)]
in the connection/detail source.
Inheritance Hierarchy
Namespace: Tekla.Structures.Plugins
Assembly: Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
The AutoDirectionTypeAttribute type exposes the following members.
Constructors
Name | Description | |
---|---|---|
AutoDirectionTypeAttribute(Int32) |
The custom attribute [AutoDirectionType()] uses this to store the auto direction type to the system.
This is not to be used by itself.
| |
AutoDirectionTypeAttribute(AutoDirectionTypeEnum) |
The custom attribute [AutoDirectionType()] uses this to store the auto direction type to the system.
This is not to be used by itself.
|
Properties
Name | Description | |
---|---|---|
Type |
The custom attribute [AutoDirectionType()] uses this to store the auto direction type to the system.
This is not to be used by itself.
|
See Also