AttributesBase Class |
The AttributesBase class is the class that all the main attributes that can load attribute files inherit from.
Inheritance Hierarchy
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The AttributesBase type exposes the following members.
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
| |
LoadAttributes |
Loads the attributes from the specified file.
|
See Also
Reference
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingBoltBoltAttributes
Tekla.Structures.DrawingDetailMarkDetailMarkAttributes
Tekla.Structures.DrawingDimensionSetBaseAttributes
Tekla.Structures.DrawingDrawingObjectNoAttributes
Tekla.Structures.DrawingEdgeChamferEdgeChamferAttributes
Tekla.Structures.DrawingEmbeddedObjectAttributes
Tekla.Structures.DrawingGraphicObjectGraphicObjectAttributes
Tekla.Structures.DrawingGridGridAttributes
Tekla.Structures.DrawingGridLineGridLineAttributes
Tekla.Structures.DrawingLayoutAttributes
Tekla.Structures.DrawingLevelMarkLevelMarkAttributes
Tekla.Structures.DrawingLinkAttributes
Tekla.Structures.DrawingMarkBaseMarkBaseAttributes
Tekla.Structures.DrawingPartPartAttributes
Tekla.Structures.DrawingPourBreakPourBreakAttributes
Tekla.Structures.DrawingPourObjectPourAttributes
Tekla.Structures.DrawingReferenceModelReferenceModelAttributes
Tekla.Structures.DrawingReinforcementBaseReinforcementBaseAttributes
Tekla.Structures.DrawingSectionMarkBaseSectionMarkAttributes
Tekla.Structures.DrawingStraightDimensionStraightDimensionAttributes
Tekla.Structures.DrawingSurfacingSurfacingAttributes
Tekla.Structures.DrawingSymbolSymbolAttributes
Tekla.Structures.DrawingTextTextAttributes
Tekla.Structures.DrawingViewViewAttributes
Tekla.Structures.DrawingWeldWeldAttributes
Tekla.Structures.DrawingWeldMarkWeldMarkAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingBoltBoltAttributes
Tekla.Structures.DrawingDetailMarkDetailMarkAttributes
Tekla.Structures.DrawingDimensionSetBaseAttributes
Tekla.Structures.DrawingDrawingObjectNoAttributes
Tekla.Structures.DrawingEdgeChamferEdgeChamferAttributes
Tekla.Structures.DrawingEmbeddedObjectAttributes
Tekla.Structures.DrawingGraphicObjectGraphicObjectAttributes
Tekla.Structures.DrawingGridGridAttributes
Tekla.Structures.DrawingGridLineGridLineAttributes
Tekla.Structures.DrawingLayoutAttributes
Tekla.Structures.DrawingLevelMarkLevelMarkAttributes
Tekla.Structures.DrawingLinkAttributes
Tekla.Structures.DrawingMarkBaseMarkBaseAttributes
Tekla.Structures.DrawingPartPartAttributes
Tekla.Structures.DrawingPourBreakPourBreakAttributes
Tekla.Structures.DrawingPourObjectPourAttributes
Tekla.Structures.DrawingReferenceModelReferenceModelAttributes
Tekla.Structures.DrawingReinforcementBaseReinforcementBaseAttributes
Tekla.Structures.DrawingSectionMarkBaseSectionMarkAttributes
Tekla.Structures.DrawingStraightDimensionStraightDimensionAttributes
Tekla.Structures.DrawingSurfacingSurfacingAttributes
Tekla.Structures.DrawingSymbolSymbolAttributes
Tekla.Structures.DrawingTextTextAttributes
Tekla.Structures.DrawingViewViewAttributes
Tekla.Structures.DrawingWeldWeldAttributes
Tekla.Structures.DrawingWeldMarkWeldMarkAttributes