Arc Constructor (Point, Point, Vector, Double) |
Constructs a new arc geometry
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
Parameters
- centerPoint
- Type: Tekla.Structures.Geometry3dPoint
Center point of the arc. - startPoint
- Type: Tekla.Structures.Geometry3dPoint
StartPoint point of the arc. - normal
- Type: Tekla.Structures.Geometry3dVector
Normal vector of the arc, defines the axis of rotation of the start vector. - deltaAngleRadians
- Type: SystemDouble
Angle of the arc in radians. From 0 to 2*PI.
Exceptions
Exception | Condition |
---|---|
ArgumentException | Throws when input values are not defined correctly |
See Also