Arc Class

Represents an arc geometry
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Geometry3dArc

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class Arc : ICurve, IEquatable<ICurve>

The Arc type exposes the following members.

Constructors
  NameDescription
Public methodArc(Point, Point, Point)
Constructs a new arc geometry
Public methodArc(Point, Point, Vector, Double)
Constructs a new arc geometry
Public methodArc(Point, Vector, Vector, Double, Double)
Constructs a new arc geometry
Top
Properties
  NameDescription
Public propertyAngle
Gets angle of the arc in radians.
Public propertyArcMiddlePoint
Gets the point located at the middle of the arc
Public propertyCenterPoint
Gets or sets center point of the arc.
Public propertyEndPoint
Gets or sets end point of the arc.
Public propertyLength
Returns the length of the arc
Public propertyNormal
Gets normal of the arc, which defines the axis of rotation of the radial vector pointing to the start point of the arc.
Public propertyRadius
Gets the radius of the arc.
Public propertyStartDirection
Gets the unit vector which points from the center point to the start point of the arc, which defines the X axis of the arc coordinate system.
Public propertyStartPoint
Gets or sets start point of the arc.
Public propertyStartTangent
Gets the unit vector tangent to the start point which defines the Y axis of the arc coordinate system
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next