ApplicationWindowBase Class |
The ApplicationWindowBase class is the base class for all Tekla Structures WPF dialogs.
The class provides localization, unit conversion and data storage
(temporary and file-based) among other things.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.WindowsWindow
Tekla.Structures.DialogWindowBase
Tekla.Structures.DialogApplicationWindowBase
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.WindowsWindow
Tekla.Structures.DialogWindowBase
Tekla.Structures.DialogApplicationWindowBase
Namespace: Tekla.Structures.Dialog
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
The ApplicationWindowBase type exposes the following members.
Constructors
Name | Description | |
---|---|---|
ApplicationWindowBase |
The default constructor that does not need parameters.
Initializes the window, property binding can be initialized with InitializeDataStorage()-method.
|
Properties
Name | Description | |
---|---|---|
Localization |
The localization instance for the dialog. Each dialog has its own localization instance
that has read the localization files needed for that dialog.
(Inherited from WindowBase.) | |
LocExtension |
The localization instance for the dialog. Each dialog has its own localization instance
that has read the localization files needed for that dialog.
(Inherited from WindowBase.) | |
UseDefaultStyle |
Use default style in all the window controls or not.
If the property is not set in the window constructor the default value (true) is used.
(Inherited from WindowBase.) |
Methods
Name | Description | |
---|---|---|
ApplyValues |
Loads the dialog values from a file and performs Apply on the loaded values.
To match the files to a certain dialog, the file suffix is set as the dialog type's name.
(Inherited from WindowBase.) | |
GetConnectionStatus |
Returns true if a proper connection to the Tekla Structures process has been established.
Currently, there's no way to re-establish the connection.
(Inherited from WindowBase.) | |
InitializeDataStorage |
Initializes the datastorage and registers property bindings for defined viewmodel.
| |
InitializeWindow |
Prepares the data storage for the dialog and scans through the fields.
(Inherited from WindowBase.) | |
LoadValues |
Loads the dialog values from a file. To match the files to a certain dialog,
the file suffix is set as the dialog type's name.
(Inherited from WindowBase.) | |
ModifyValues |
Loads the dialog values from a file and performs Modify on the loaded values.
To match the files to a certain dialog, the file suffix is set as the dialog type's name.
(Inherited from WindowBase.) | |
SaveValues |
Serializes the dialog values to an xml file.
(Inherited from WindowBase.) | |
ShowWindow |
Displays the window.
(Inherited from WindowBase.) | |
UpdateDataStorageFromViewModel |
DO NOT USE! For internal usage only!
(Inherited from WindowBase.) |
See Also