AngleDimension Constructor (ViewBase, Point, Vector, Vector, Double)

Creates a new angle dimension instance using the origin and two vectors relative to the origin.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public AngleDimension(
	ViewBase View,
	Point Origin,
	Vector Vector1,
	Vector Vector2,
	double Distance
)

Parameters

View
Type: Tekla.Structures.DrawingViewBase
The view to be used.
Origin
Type: Tekla.Structures.Geometry3dPoint
The origin to be used.
Vector1
Type: Tekla.Structures.Geometry3dVector
The first vector to be used.
Vector2
Type: Tekla.Structures.Geometry3dVector
The second vector to be used.
Distance
Type: SystemDouble
The distance to be used.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next