AngleDimension Constructor (ViewBase, Point, Point, Point, Double)

Creates a new angle dimension instance using three points.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public AngleDimension(
	ViewBase View,
	Point Origin,
	Point Point1,
	Point Point2,
	double Distance
)

Parameters

View
Type: Tekla.Structures.DrawingViewBase
The view to be used.
Origin
Type: Tekla.Structures.Geometry3dPoint
The origin to be used.
Point1
Type: Tekla.Structures.Geometry3dPoint
The first point to be used.
Point2
Type: Tekla.Structures.Geometry3dPoint
The second point to be used.
Distance
Type: SystemDouble
The distance of the angle sign from the origin to the first point.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next