AnalysisVolume Class |
The AnalysisVolume class contains information related to analysis volumes.
Inheritance Hierarchy
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
The AnalysisVolume type exposes the following members.
Constructors
Name | Description | |
---|---|---|
AnalysisVolume | Initializes a new instance of the AnalysisVolume class |
Properties
Name | Description | |
---|---|---|
AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) | |
AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) | |
FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) | |
FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) | |
FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) | |
FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) | |
ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) | |
Material |
The material of the analysis volume.
| |
Profile |
The profile of the analysis volume.
| |
Volume |
The volume item.
| |
VolumeHoles |
The volume holes.
|
Methods
Name | Description | |
---|---|---|
Select |
Selects an analysis volume.
The ID has to be set.
(Overrides AnalysisObjectSelect.) |
See Also