AnalysisSubSection Class |
The AnalysisSubSection class contains information related to analysis subsections.
Inheritance Hierarchy
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
The AnalysisSubSection type exposes the following members.
Constructors
Name | Description | |
---|---|---|
AnalysisSubSection | Initializes a new instance of the AnalysisSubSection class |
Properties
Name | Description | |
---|---|---|
AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) | |
AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) | |
B |
The B value.
| |
B1 |
The B1 value.
| |
B2 |
The B2 value.
| |
B3 |
The B3 value.
| |
B4 |
The B4 value.
| |
FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) | |
FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) | |
FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) | |
FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) | |
H |
The H value.
| |
H1 |
The H1 value.
| |
H2 |
The H2 value.
| |
ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) | |
IsHole |
Defines whether the subsection is a hole.
| |
Material |
The material of the subsection.
| |
OffsetAngle |
The offset angle.
| |
OffsetY |
The offset in the direction of the Y-axis.
| |
OffsetZ |
The offset in the direction of the Z-axis.
| |
Points |
The points of the subsection.
| |
R1 |
The R1 value.
| |
R2 |
The R2 value.
| |
SubType |
The subtype of the subsection.
| |
T1 |
The T1 value.
| |
T2 |
The T2 value.
| |
T3 |
The T3 value.
| |
T4 |
The T4 value.
| |
TF |
The TF value.
| |
TW |
The TW value.
| |
Type |
The type of the subsection.
|
Methods
Name | Description | |
---|---|---|
Select |
Selects an analysis subsection.
The analysis subsection identifier must be set.
(Overrides AnalysisObjectSelect.) |
See Also