AnalysisResult Class |
The AnalysisResult class contains analysis result information.
Inheritance Hierarchy
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
The AnalysisResult type exposes the following members.
Constructors
Name | Description | |
---|---|---|
AnalysisResult |
Creates a new analysis result instance.
|
Properties
Name | Description | |
---|---|---|
LoadCase |
The load case.
The real load cases have positive values 1, 2, 3, ...
For min/max queries LoadCaseForMinMaxEnum can be used.
| |
LoadCaseInfo |
The load case info (optional, max length 128).
| |
LoadCaseName |
The load case name (max length 64).
| |
LoadCaseType |
The load case type.
| |
ModId |
The time stamp of the result.
| |
ObjectId |
The identifier of the object.
If ObjectType is OBJECT_TYPE_PART, ObjectId is (physical) part ID.
If ObjectType is OBJECT_TYPE_MEMBER, ObjectId is the bar number when analysis bars are used in integration,
otherwise ObjectId is the member number.
If ObjectType is OBJECT_TYPE_AREA, ObjectId is the area number.
| |
ObjectType |
The object type. In result query the only supported type is the physical member (the part).
| |
Position |
The position on the part's START/END/...
| |
PositionCoordX |
Global coordinate X (mm) when inserting result.
Local (part) coordinate X (mm) when getting results.
| |
PositionCoordY |
Global coordinate Y (mm) when inserting result.
Local (part) coordinate Y (mm) when getting results.
| |
PositionCoordZ |
Global coordinate Z (mm) when inserting result.
Local (part) coordinate Z (mm) when getting results.
| |
PositionTolerance |
The position's coordinate tolerance.
| |
Value |
The result value.
| |
ValueType |
The result value type.
|
Methods
Name | Description | |
---|---|---|
Delete |
Delete analysis results by the given key.
| |
DeleteAll |
Delete all analysis results.
| |
DeleteLoadcase |
Delete analysis results by load case.
| |
GetResultObjectIds |
Get ID numbers of objects with results.
| |
GetResults |
Get analysis results.
| |
Insert |
Insert analysis result. Results are always stored to physical parts.
When OBJECT_TYPE_MEMBER or OBJECT_TYPE_AREA is used the analysis model must be active.
All results for given part must be inserted within one commit (CommitChanges),
older results of this part are removed automatically.
| |
QueryAnalysisResult |
Queries an analysis result.
|
Examples
The following example queries a single analysis result value.
using Tekla.Structures.Analysis; public class Example { public void Example1() { int PartId = 0; AnalysisResult AnalysisResult = new AnalysisResult(); AnalysisResult.ObjectType = AnalysisResult.ObjectTypeEnum.OBJECT_TYPE_PART; AnalysisResult.ObjectId = PartId; AnalysisResult.LoadCase = (int)AnalysisResult.LoadCaseForMinMaxEnum.LOADCASE_WITH_MAX_ABSOLUTE_VALUE; AnalysisResult.Position = AnalysisResult.ResultPositionEnum.POSITION_BEAM_START_POINT; AnalysisResult.PositionCoordX = 0.0; AnalysisResult.PositionCoordY = 0.0; AnalysisResult.PositionCoordZ = 0.0; AnalysisResult.PositionTolerance = 0.1; AnalysisResult.ValueType = AnalysisResult.ValueTypeEnum.VALUETYPE_SHEAR_Y; bool Result = AnalysisResult.QueryAnalysisResult(); double ResultValue = AnalysisResult.Value; } }
See Also