AnalysisRestraintData Class |
The AnalysisRestraintData class contains the restraint data for an
analysis part.
Inheritance Hierarchy
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
The AnalysisRestraintData type exposes the following members.
Constructors
Name | Description | |
---|---|---|
AnalysisRestraintData |
Creates a new instance of an analysis restraint data.
|
Properties
Name | Description | |
---|---|---|
LocalCoordinateSystem |
The local coordinate system.
| |
ReleaseType |
The release type.
| |
RxSpring |
The rotation in the X-axis direction (Nmm/rad).
| |
RxType |
The restraint type for the rotation in the X-axis direction.
| |
RySpring |
The rotation in the Y-axis direction (Nmm/rad).
| |
RyType |
The restraint type for the rotation in the Y-axis direction.
| |
RzSpring |
The rotation in the Z-axis direction (Nmm/rad).
| |
RzType |
The restraint type for the rotation in the Z-axis direction.
| |
Supported |
The support condition.
| |
UxSpring |
The displacement in the X-axis direction (N/mm).
| |
UxType |
The restraint type for the displacement in the X-axis direction.
| |
UySpring |
The displacement in the Y-axis direction (N/mm).
| |
UyType |
The restraint type for the displacement in the Y-axis direction.
| |
UzSpring |
The displacement in the Z-axis direction (N/mm).
| |
UzType |
The restraint type for the displacement in the Z-axis direction.
|
See Also