AnalysisPartPositionProperties Class |
The AnalysisPartPositionProperties class contains information related to analysis part position properties.
Inheritance Hierarchy
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
The AnalysisPartPositionProperties type exposes the following members.
Constructors
Name | Description | |
---|---|---|
AnalysisPartPositionProperties | Initializes a new instance of the AnalysisPartPositionProperties class |
Properties
Name | Description | |
---|---|---|
AxisCoordinateX |
The axis coordinate in the X direction.
| |
AxisCoordinateY |
The axis coordinate in the Y direction.
| |
AxisCoordinateZ |
The axis coordinate in the Z direction.
| |
AxisLocation |
The axis location of the analysis part.
| |
AxisModifierX |
The axis modifier in the X direction.
| |
AxisModifierY |
The axis modifier in the Y direction.
| |
AxisModifierZ |
The axis modifier in the Z direction.
| |
AxisOffset |
The axis offset of the analysis part (in the global coordinate system).
| |
KeepAxis |
The keep axis setting of the analysis part.
| |
LongitudinalOffsetMode |
The longitudinal offset mode.
|
See Also