AnalysisPartPositionPropertiesAxisLocationEnum Enumeration |
The axis location.
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
REFERENCE_AXIS_WITH_ECCENTRICITY | 0 | The axis location is the reference axis with eccentricity. | |
REFERENCE_AXIS | 1 | The axis location is the reference axis. | |
NEUTRAL_AXIS | 3 | The axis location is the neutral axis. | |
TOP_PLANE | 4 | The axis location is the top plane. | |
MIDDLE_PLANE | 5 | The axis location is the middle plane. | |
BOTTOM_PLANE | 6 | The axis location is the bottom plane. | |
LEFT_PLANE | 7 | The axis location is the left plane. | |
RIGHT_PLANE | 8 | The axis location is the right plane. | |
MIDDLE_PLANE_BY_LEFT_RIGHT | 9 | The axis location is the middle plane by the left point. | |
TOP_LEFT | 10 | The axis location is at the top left corner. | |
TOP_CENTER | 11 | The axis location is at top center. | |
TOP_RIGHT | 12 | The axis location is at the top right corner. | |
MIDDLE_LEFT | 13 | The axis location is at the middle left corner. | |
MIDDLE_CENTER | 14 | The axis location is at middle center. | |
MIDDLE_RIGHT | 15 | The axis location is at the middle right corner. | |
BOTTOM_LEFT | 16 | The axis location is at the bottom left corner. | |
BOTTOM_CENTER | 17 | The axis location is at bottom center. | |
BOTTOM_RIGHT | 18 | The axis location is at the bottom right corner. |
See Also