AnalysisPart Class

The AnalysisPart class contains information related to analysis parts.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisPart : AnalysisObject

The AnalysisPart type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisPart
Initializes a new instance of the AnalysisPart class.
Top
Properties
  NameDescription
Public propertyAnalysisAreas
The analysis areas of the analysis part.
Public propertyAnalysisBars
The analysis bars of the analysis part.
Public propertyAnalysisDesignCode
The analysis design code of the analysis part.
Public propertyAnalysisPartAnalysisProperties
The analysis part analysis properties.
Public propertyAnalysisPartAreaAttributes
The analysis part area attributes.
Public propertyAnalysisPartBarAttributes
The analysis part bar attributes.
Public propertyAnalysisPartCompositeProperties
The analysis part composite properties.
Public propertyAnalysisPartLoadingProperties
The analysis part loading properties.
Public propertyAnalysisPartPositionProperties
The analysis part position properties.
Public propertyAnalysisPartSpanningProperties
The analysis part spanning properties.
Public propertyAnalysisType
The analysis type of the analysis part.
Public propertyAnalysisVolumes
The analysis volumes of the analysis part.
Public propertyCoordinateSystem
The coordinate system of the analysis part.
Public propertyCurvature
The curvature of the analysis part.
Public propertyLoadBearingOrder
The load bearing order.
Public propertyMaterial
The material of the analysis part.
Public propertyOverrideProfile
The override profile of the analysis part. In case of tapered profile, only the name is available, and more details are available in the start/end properties of the analysis members.
Public propertyPartID
The identifier of the physical part.
Public propertyPartName
The name of the physical part.
Public propertyPartType
The type of the physical part.
Public propertyProfile
The profile of the analysis part. Note: OverrideProfile may exist to replace this. In case of tapered profile, only the name is available, ID is 0 and values are not returned. More details are available in the start/end properties of the analysis members.
Public propertySnapDistance
The snap distance. Use 0.0 for manual connectivity, positive value for automatic connectivity.
Public propertyUpDirection
The up direction of the analysis part (in the global coordinate system). The axis vector (connecting member end nodes) and the up direction vector define the local XY plane of the member. The local Z can be calculated as localZ = localX x UpDirection (cross product), and after this localY = localZ x localX (cross product).
Top
Methods
  NameDescription
Public methodAdd(AnalysisArea)
Adds an analysis area to the analysis part.
Public methodAdd(AnalysisBar)
Adds an analysis bar to the analysis part.
Public methodDelete
Deletes an analysis part. The method is not implemented.
Public methodDeleteAnalysisPart
Deletes the analysis part by ID.
Public methodGetAnalysisAreas
Gets the analysis areas of the analysis part.
Public methodGetAnalysisBars
Gets the analysis bars of the analysis part.
Public methodGetAnalysisVolumes
Gets the analysis volumes of the analysis part.
Public methodGetMainParts
Get the main analysis parts of this analysis part. There are no main analysis parts if this is not a sub analysis part.
Public methodGetSubParts
Get the sub analysis parts of this analysis part. There are no sub analysis parts if this is not a main analysis part.
Public methodInsert
Inserts a new analysis part into the Tekla Structures model. The AnalysisModelName has to be set.
Public methodIsMainPart
Check if this analysis part is a main analysis part (has sub analysis parts).
Public methodIsSubPart
Check if this analysis part is a sub analysis part.
Public methodModify
Modifies an analysis part. The ID, or the PartID and the AnalysisModelName, has to be set.
Public methodMovePosition
Move analysis position.
Public methodSelect
Selects an analysis part. The ID, or the PartID and the AnalysisModelName, has to be set.
(Overrides AnalysisObjectSelect.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next