AnalysisPartAnalysisTypeEnum Enumeration

The analysis types.

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public enum AnalysisTypeEnum
Members
  Member nameValueDescription
ANALYSIS_TYPE_IGNORE1 The ignore analysis type.
ANALYSIS_TYPE_TRUSS2 The truss analysis type.
ANALYSIS_TYPE_RIGID_DIAPHRAGM3 The rigid diaphragm analysis type.
ANALYSIS_TYPE_TENSION_ONLY4 The tension only analysis type.
ANALYSIS_TYPE_COMPRESSION_ONLY5 The compression only analysis type.
ANALYSIS_TYPE_SHELL6 The shell analysis type.
ANALYSIS_TYPE_SHEAR_WALL7 The wall analysis type.
ANALYSIS_TYPE_BEAM8 The beam analysis type.
ANALYSIS_TYPE_MEMBRANE9 The membrane analysis type.
ANALYSIS_TYPE_PLATE10 The plate analysis type.
ANALYSIS_TYPE_MAT_FOUNDATION11 The mat foundation analysis type.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next