AnalysisObjectAnalysisObjectEnum Enumeration |
All subclasses of analysis objects are defined here. This enumeration can be used to
select certain types of analysis objects.
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
ANALYSIS_NOT_DEFINED | 0 | The analysis object type is not defined. | |
ANALYSIS_MODEL | 1 | This type is for selecting analysis models from the current Tekla Structures model. | |
ANALYSIS_PART | 2 | This type is for selecting analysis parts from the current analysis model. | |
ANALYSIS_BAR | 3 | This type is for selecting analysis bars from the current analysis model. | |
ANALYSIS_AREA | 4 | This type is for selecting analysis areas from the current analysis model. | |
ANALYSIS_VOLUME | 5 | This type is for selecting analysis volumes from the current analysis model. | |
ANALYSIS_MEMBER | 6 | This type is for selecting analysis members from the current analysis model. | |
ANALYSIS_DECOMPOSED_LOAD_NODE | 7 | This type is for selecting decomposed node loads from the current analysis model. | |
ANALYSIS_DECOMPOSED_LOAD_BAR | 8 | This type is for selecting decomposed bar loads from the current analysis model. | |
ANALYSIS_DECOMPOSED_LOAD_AREA | 9 | This type is for selecting decomposed area loads from the current analysis model. | |
ANALYSIS_DECOMPOSED_LOAD_MEMBER | 10 | This type is for selecting decomposed member loads from the current analysis model. | |
ANALYSIS_DECOMPOSED_LOAD_SELFWEIGHT | 11 | This type is for selecting decomposed selfweight loads from the current analysis model. | |
ANALYSIS_DECOMPOSED_LOAD_TEMPERATURE | 12 | This type is for selecting decomposed temperature loads from the current analysis model. | |
ANALYSIS_AREA_POLYGON | 13 | This type is for selecting area polygons from the current analysis model. | |
ANALYSIS_AREA_HOLE | 14 | This type is for selecting area holes from the current analysis model. | |
ANALYSIS_EDGE | 15 | This type is for selecting area edges from the current analysis model. | |
ANALYSIS_EDGE_HOLE | 16 | This type is for selecting area hole edges from the current analysis model. | |
ANALYSIS_POSITION_BAR | 17 | This type is for selecting bar positions from the current analysis model. | |
ANALYSIS_POSITION_AREA | 18 | This type is for selecting area polygon positions from the current analysis model. | |
ANALYSIS_POSITION_AREA_INNER | 19 | This type is for selecting area inner positions from the current analysis model. | |
ANALYSIS_POSITION_AREA_HOLE | 20 | This type is for selecting area hole positions from the current analysis model. | |
ANALYSIS_POSITION_EDGE_SPLIT | 21 | This type is for selecting edge split positions from the current analysis model. | |
ANALYSIS_POSITION_EDGE_SPLIT_HOLE | 22 | This type is for selecting edge split hole positions from the current analysis model. | |
ANALYSIS_POSITION_FACE | 23 | This type is for selecting face positions from the current analysis model. | |
ANALYSIS_NODE | 24 | This type is for selecting analysis nodes from the current analysis model. | |
ANALYSIS_NODE_LINK | 25 | This type is for selecting analysis node links from the current analysis model. | |
ANALYSIS_DESIGN_PARAMETER | 26 | This type is for selecting analysis design parameters from the current analysis model. | |
ANALYSIS_DESIGN_PARAMETER_MULTI | 27 | This type is for selecting analysis design multi parameters from the current analysis model. | |
ANALYSIS_MODEL_CONNECTIVITY_RULE | 28 | This type is for selecting analysis connectivity rules from the current analysis model. | |
ANALYSIS_FACE | 29 | This type is for selecting analysis faces from the current analysis model. | |
ANALYSIS_VOLUME_ITEM | 30 | This type is for selecting analysis volume items from the current analysis model. | |
ANALYSIS_CROSS_SECTION | 31 | This type is for selecting analysis cross sections from the current analysis model. | |
ANALYSIS_SUB_SECTION | 32 | This type is for selecting analysis subsections from the current analysis model. | |
ANALYSIS_MATERIAL | 33 | This type is for selecting analysis materials from the current analysis model. | |
ANALYSIS_CROSS_SECTION_GROUP | 34 | This type is for selecting analysis cross section groups from the current analysis model. | |
ANALYSIS_RIGID_DIAPHRAGM | 35 | This type is for selecting analysis rigid diaphragms from the current analysis model. | |
ANALYSIS_LOAD_GROUP | 36 | This type is for selecting analysis load groups from the current analysis model. | |
ANALYSIS_LOAD_COMBINATION | 37 | This type is for selecting analysis load combinations from the current analysis model. | |
ANALYSIS_MODEL_LOAD | 38 | This type is for selecting model loads from the current analysis model. |
See Also