![]() | AnalysisNode Class |
The AnalysisNode class contains information related to analysis nodes.

Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3

The AnalysisNode type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalysisNode |
Initializes a new instance of the AnalysisNode class.
|

Name | Description | |
---|---|---|
![]() | AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) |
![]() | AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) |
![]() | CoordinateSystem |
The coordinate system of the analysis node.
|
![]() | FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) |
![]() | IsUserNode |
Indicates whether the analysis node is a user node.
|
![]() | IsUserSupport |
Indicates whether the analysis node has a user node.
|
![]() | Label |
The label of the analysis node.
|
![]() | Position |
The position of the analysis node (in the global coordinate system).
|
![]() | Support |
The support of the analysis node.
|

Name | Description | |
---|---|---|
![]() | Delete |
Deletes an analysis node.
The ID has to be set.
|
![]() | GetAnalysisNodeLinks |
Get analysis nodelinks connected to node.
|
![]() | GetAnalysisParts |
Get analysis parts connected to node.
|
![]() | Insert |
Inserts an analysis node.
The AnalysisModelName has to be set.
|
![]() | Modify |
Modifies an analysis node.
The ID has to be set.
|
![]() | Select |
Selects an analysis node.
The ID has to be set.
(Overrides AnalysisObjectSelect.) |