AnalysisModelHandler Class |
The AnalysisModelHandler class contains information related to analysis models.
Inheritance Hierarchy
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
The AnalysisModelHandler type exposes the following members.
Constructors
Name | Description | |
---|---|---|
AnalysisModelHandler | Initializes a new instance of the AnalysisModelHandler class |
Methods
Name | Description | |
---|---|---|
AddLoad |
Adds a load to the analysis model.
The ConstructionMethod must be SELECTED_PARTS, SELECTED_PARTS_AND_LOADS or FLOOR_BY_SELECTED_PARTS_AND_LOADS.
| |
AddPart |
Adds a part to the analysis model.
The ConstructionMethod must be SELECTED_PARTS, SELECTED_PARTS_AND_LOADS or FLOOR_BY_SELECTED_PARTS_AND_LOADS.
| |
GetActiveModel |
Gets the active model.
| |
RemoveLoad |
Removes a load from the analysis model.
The ConstructionMethod must be SELECTED_PARTS, SELECTED_PARTS_AND_LOADS or FLOOR_BY_SELECTED_PARTS_AND_LOADS.
| |
RemovePart |
Removes a part from the analysis model.
The ConstructionMethod must be SELECTED_PARTS, SELECTED_PARTS_AND_LOADS or FLOOR_BY_SELECTED_PARTS_AND_LOADS.
| |
SetActiveModel |
Sets the active model.
The AnalysisModelName or ID has to be set.
|
Examples
using Tekla.Structures.Analysis; public class Class { public void Example() { Analysis Analysis = new Analysis(); AnalysisObjectSelector AnalysisObjectSelector = Analysis.GetAnalysisObjectSelector(); AnalysisObjectEnumerator AnalysisObjectEnumerator = AnalysisObjectSelector.GetAllObjectsWithType(AnalysisObject.AnalysisObjectEnum.ANALYSIS_MODEL, ""); while(AnalysisObjectEnumerator.MoveNext()) { AnalysisModel AnalysisModel = AnalysisObjectEnumerator.Current as AnalysisModel; if(AnalysisModel == null) continue; } } }
See Also