AnalysisModel Class |
The AnalysisModel class contains information related to analysis models.
Inheritance Hierarchy
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
The AnalysisModel type exposes the following members.
Constructors
Name | Description | |
---|---|---|
AnalysisModel |
Initializes a new instance of the AnalysisModel class.
|
Properties
Name | Description | |
---|---|---|
AnalysisConnectivityRules |
Gets or sets the analysis model connectivity rules.
| |
AnalysisEngine |
Gets or sets the analysis engine of the analysis model.
| |
AnalysisLoadCombinations |
Gets the analysis load combinations of the analysis model.
| |
AnalysisLoadGroups |
Gets the analysis load groups of the analysis model.
| |
AnalysisMethod |
Gets or sets the analysis method of the analysis model.
| |
AnalysisModelDesignProperties |
Gets or sets the analysis model design properties.
| |
AnalysisModelJobProperties |
Gets or sets the analysis model job properties.
| |
AnalysisModelModalAnalysisProperties |
Gets or sets the analysis model modal analysis properties.
| |
AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) | |
AnalysisModelOutputProperties |
Gets or sets the analysis model output properties.
| |
AnalysisModelSeismicProperties |
Gets or sets the analysis model seismic properties.
| |
AnalysisModelSpectrumProperties |
Gets or sets the analysis model spectrum properties
| |
AnalysisNodeLinks |
Gets the analysis node links of the analysis model.
| |
AnalysisNodes |
Gets the analysis nodes of the analysis model.
| |
AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) | |
AnalysisParts |
Gets the analysis parts of the analysis model.
| |
AnalysisRigidDiaphragms |
Gets the analysis rigid diaphragms of the analysis model.
| |
AutodetectSecondaries |
Gets or sets a value indicating whether bracing members are detected automatically.
| |
BracingFilterName |
Gets or sets the bracing filter name.
| |
ConstructionMethod |
Gets or sets the construction method of the analysis model.
| |
FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) | |
FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) | |
FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) | |
FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) | |
FilterName |
Gets or sets the filter name of the analysis model.
| |
ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) | |
IncludeImperfections |
Gets or sets a value indicating whether imperfections are to be included.
| |
MemberAxislocation |
Gets or sets the axis location of the members.
| |
MemberEndReleaseMethodByJoint |
Gets or sets a value indicating whether the end releases are set by joint properties.
| |
ModelUpdateModificationIdentifier |
Gets or sets the identifier of the model update modification.
| |
NodePositionTolerance |
Gets or sets the node position tolerance of the analysis model.
| |
NumberOfIterations |
Gets or sets the number of iterations of the analysis model.
| |
PhysicalFreezed |
Gets or sets a value indicating whether the physical objects are frozen.
| |
PhysicalFrozen |
Gets or sets a value indicating whether the physical objects are frozen.
| |
RelativeAccuracy |
Gets or sets the relative accuracy of the analysis model.
| |
ResultsFreezed |
Gets or sets a value indicating whether the results are frozen.
| |
ResultsFrozen |
Gets or sets a value indicating whether the results are frozen.
| |
ResultsModificationIdentifier |
Gets or sets the results modification identifier.
| |
ResultsTime |
Gets or sets the results time.
| |
SecondaryFilterName |
Gets or sets the bracing filter name.
| |
SecondaryKeepAxis |
Gets or sets the secondary keep axis settings.
Not used, bracing/secondary members always have KEEP_AXIS_NO initially.
| |
SecondaryMemberFilterName |
Gets or sets the secondary member filter name.
| |
SnapDistance |
Gets or sets the snap distance of the analysis model.
| |
UseModelMerge |
Gets or sets a value indicating whether model merge is used.
| |
UseTrueCurvedMembers |
Gets or sets a value indicating whether members are true curved.
| |
UseTwinProfiles |
Gets or sets a value indicating whether twin profiles are used.
|
Methods
Name | Description | |
---|---|---|
Delete |
Deletes an analysis model.
The AnalysisModelName has to be set.
| |
GetIssues |
Get analysis model issues.
| |
Insert |
Inserts a new analysis model into the Tekla Structures model.
The AnalysisModelName has to be set.
| |
Modify |
Modifies an analysis model.
The AnalysisModelName has to be set.
| |
Select |
Selects an analysis model. Updates the model.
The AnalysisModelName or ID has to be set.
(Overrides AnalysisObjectSelect.) | |
Select(Boolean) |
Selects an analysis model.
The AnalysisModelName or ID has to be set.
|
Fields
Name | Description | |
---|---|---|
PART_DEFAULTS_MODEL_NAME |
The analysis model name for default analysis properties of a part.
|
Examples
using Tekla.Structures.Analysis; public class Class { public void Example() { Analysis Analysis = new Analysis(); AnalysisObjectSelector AnalysisObjectSelector = Analysis.GetAnalysisObjectSelector(); AnalysisObjectEnumerator AnalysisObjectEnumerator = AnalysisObjectSelector.GetAllObjectsWithType(AnalysisObject.AnalysisObjectEnum.ANALYSIS_MODEL, ""); while(AnalysisObjectEnumerator.MoveNext()) { AnalysisModel AnalysisModel = AnalysisObjectEnumerator.Current as AnalysisModel; if(AnalysisModel == null) continue; } } }
See Also