AnalysisMaterial Class

The AnalysisMaterial class contains the material information.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisMaterial : AnalysisObject

The AnalysisMaterial type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisMaterial
Initializes a new instance of the AnalysisMaterial class.
Top
Properties
  NameDescription
Public propertyAnalysisModelName
Gets or sets the analysis model name.
(Inherited from AnalysisObject.)
Public propertyAnalysisObjectType
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.)
Public propertyDampingFactor
Gets or sets the damping factor of the material.
Public propertyDensity
Gets or sets the density of the material.
Public propertyFatherObject2ID
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.)
Public propertyFatherObject2Type
Gets or sets the type of the father object.
(Inherited from AnalysisObject.)
Public propertyFatherObjectID
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.)
Public propertyFatherObjectType
Gets or sets the type of the father object.
(Inherited from AnalysisObject.)
Public propertyID
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.)
Public propertyMaterialType
Gets or sets tThe type of the material.
Public propertyModulusOfElasticity
Gets or sets the modulus of elasticity of the analysis material.
Public propertyName
Gets or sets the name of the analysis material.
Public propertyPoissonsRatio
Gets or sets the Poisson's ratio of the analysis material.
Public propertyThermalDilatation
Gets or sets the thermal dilatation of the analysis material.
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next