AnalysisMaterial Class

The AnalysisMaterial class contains the material information.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisMaterial : AnalysisObject

The AnalysisMaterial type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisMaterial
Initializes a new instance of the AnalysisMaterial class.
Top
Properties
  NameDescription
Public propertyDampingFactor
Gets or sets the damping factor of the material.
Public propertyDensity
Gets or sets the density of the material.
Public propertyMaterialType
Gets or sets tThe type of the material.
Public propertyModulusOfElasticity
Gets or sets the modulus of elasticity of the analysis material.
Public propertyName
Gets or sets the name of the analysis material.
Public propertyPoissonsRatio
Gets or sets the Poisson's ratio of the analysis material.
Public propertyThermalDilatation
Gets or sets the thermal dilatation of the analysis material.
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next