AnalysisFace Class |
The AnalysisFace class contains information related to analysis faces.
Inheritance Hierarchy
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
The AnalysisFace type exposes the following members.
Constructors
Name | Description | |
---|---|---|
AnalysisFace | Initializes a new instance of the AnalysisFace class |
Properties
Name | Description | |
---|---|---|
AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) | |
AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) | |
FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) | |
FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) | |
FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) | |
FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) | |
ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) | |
Positions |
The positions of the analysis face.
|
Methods
Name | Description | |
---|---|---|
Select |
Selects an analysis face.
(Overrides AnalysisObjectSelect.) |
See Also