![]() | AnalysisDesignParameterMulti Class |
The AnalysisDesignParameterMulti class contains information related to analysis design parameters with multi values.

SystemObject
Tekla.Structures.AnalysisAnalysisObject
Tekla.Structures.AnalysisAnalysisDesignParameterBase
Tekla.Structures.AnalysisAnalysisDesignParameterMulti
Tekla.Structures.AnalysisAnalysisObject
Tekla.Structures.AnalysisAnalysisDesignParameterBase
Tekla.Structures.AnalysisAnalysisDesignParameterMulti
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3

The AnalysisDesignParameterMulti type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalysisDesignParameterMulti(Int32) |
Initializes a new instance of the AnalysisDesignParameterMulti class.
|
![]() | AnalysisDesignParameterMulti(String, Int32, Identifier) |
Initializes a new instance of the AnalysisDesignParameterMulti class.
|

Name | Description | |
---|---|---|
![]() | AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) |
![]() | AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) |
![]() | FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) |
![]() | FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) |
![]() | ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) |
![]() | IsGeneral |
Gets or sets a value indicating whether the design parameter is general.
(Inherited from AnalysisDesignParameterBase.) |
![]() | MultiValueCount |
Gets the multi value count of the analysis design parameter.
|
![]() | Name |
Gets or sets the name of the analysis design parameter.
(Inherited from AnalysisDesignParameterBase.) |
![]() | Unit |
Gets or sets the unit of the analysis design parameter.
(Inherited from AnalysisDesignParameterBase.) |

Name | Description | |
---|---|---|
![]() | GetValue |
Gets the value specified by the index of the analysis design parameter.
|
![]() | Modify |
Modifies an analysis design parameter.
The ID has to be set.
(Overrides AnalysisDesignParameterBaseModify.) |
![]() | Select |
Selects an analysis design parameter.
(Overrides AnalysisObjectSelect.) |
![]() | SetValue |
Sets the value specified by the index of the analysis design parameter.
|