AnalysisDecomposedBarLoad Class |
The AnalysisDecomposedBarLoad class contains information related to decomposed bar loads.
Inheritance Hierarchy
SystemObject
Tekla.Structures.AnalysisAnalysisObject
Tekla.Structures.AnalysisAnalysisDecomposedLoad
Tekla.Structures.AnalysisAnalysisDecomposedBarLoad
Tekla.Structures.AnalysisAnalysisObject
Tekla.Structures.AnalysisAnalysisDecomposedLoad
Tekla.Structures.AnalysisAnalysisDecomposedBarLoad
Namespace: Tekla.Structures.Analysis
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
The AnalysisDecomposedBarLoad type exposes the following members.
Constructors
Name | Description | |
---|---|---|
AnalysisDecomposedBarLoad | Initializes a new instance of the AnalysisDecomposedBarLoad class |
Properties
Name | Description | |
---|---|---|
AnalysisLoadType |
Gets or sets the type of the analysis decomposed load.
(Inherited from AnalysisDecomposedLoad.) | |
AnalysisModelName |
Gets or sets the analysis model name.
(Inherited from AnalysisObject.) | |
AnalysisObjectType |
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.) | |
CSCode |
The CS code of the decomposed bar load.
| |
EndDistance |
The end distance of the decomposed bar load.
| |
EndValue |
The end value of the decomposed bar load.
| |
FatherObject2ID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) | |
FatherObject2Type |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) | |
FatherObjectID |
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.) | |
FatherObjectType |
Gets or sets the type of the father object.
(Inherited from AnalysisObject.) | |
ID |
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.) | |
ModelLoadGroupID |
Gets or sets the identifier of the load group.
(Inherited from AnalysisDecomposedLoad.) | |
ModelLoadID |
Gets or sets the identifier of the model load.
(Inherited from AnalysisDecomposedLoad.) | |
ObjectAttachedToID |
Gets or sets the identifier of the object the load is attached to.
(Inherited from AnalysisDecomposedLoad.) | |
ObjectAttachedToType |
Gets or sets the type of the object the load is attached to.
(Inherited from AnalysisDecomposedLoad.) | |
StartDistance |
The start distance of the decomposed bar load.
| |
StartValue |
The start value of the decomposed bar load.
|
Methods
Name | Description | |
---|---|---|
Select |
Selects an analysis decomposed bar load.
(Overrides AnalysisObjectSelect.) |
See Also