AnalysisCrossSection Class

The AnalysisCrossSection class contains information related to analysis cross sections.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisCrossSection : AnalysisObject

The AnalysisCrossSection type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisCrossSection
Creates a new instance of an analysis cross section.
Top
Properties
  NameDescription
Public propertyA
The cross section area (m2) of the analysis cross section.
Public propertyAnalysisSubSections
The subsections of the analysis cross section.
Public propertyAvy
The shear area for loads parallel to the Y-axis (m2) of the analysis cross section.
Public propertyAvz
The shear area for loads parallel to the Z-axis (m2) of the analysis cross section.
Public propertyCalculated
Indicates whether section values have been calculated.
Public propertyG
The mass per unit of length (kg/m) of the analysis cross section.
Public propertyIt
The torsion moment (m4) of the analysis cross section.
Public propertyIw
The warping constant (m6) of the analysis cross section.
Public propertyIy
The radius of gyration about the Y-axis (m) of the analysis cross section.
Public propertyIyy
The moment of inertia about the Y-axis (m4) of the analysis cross section.
Public propertyIz
The radius of gyration about the Z-axis (m) of the analysis cross section.
Public propertyIzz
The moment of inertia about the Z-axis (m4) of the analysis cross section.
Public propertyName
The name of the analysis cross section.
Public propertyWplyy
The plastic modulus about the Y-axis (m3) of the analysis cross section.
Public propertyWplzz
The plastic modulus about the Z-axis (m3) of the analysis cross section.
Public propertyWyy
The elastic modulus about the Y-axis (m3) of the analysis cross section.
Public propertyWzz
The elastic modulus about the Z-axis (m3) of the analysis cross section.
Top
Methods
  NameDescription
Public methodDelete
Deletes an analysis cross section. The AnalysisModelName and ID have to be set.
Public methodGetCrossSectionGroup
Gets the cross section group.
Public methodInsert
Inserts an analysis cross section. The AnalysisModelName has to be set.
Public methodSelect
Selects an analysis cross section. The AnalysisModelName and ID/Name have to be set.
(Overrides AnalysisObjectSelect.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next