AlongLinePlacing Class |
The AlongLinePlacing class defines a placing where the object is
located and moved along a line defined by two points.
Inheritance Hierarchy
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The AlongLinePlacing type exposes the following members.
Constructors
Name | Description | |
---|---|---|
AlongLinePlacing |
Creates a new along line placing instance.
The given two points define the line to be used for the placing.
|
Properties
Name | Description | |
---|---|---|
EndPoint |
The end point of the line that the object is placed on.
| |
StartPoint |
The start point of the line that the object is placed on.
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides PlacingBaseIsEqual(Object).) |
See Also