AlongLineOrWithLeaderLinePlacingType Class

The AlongLineOrWithLeaderLinePlacingType class defines a placing type that places the object using the along line placing as the first option. If there is no room for the first option the fallback option will be used. The fallback option is placing the object with a leader line.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingPreferredPlacingTypeBase
    Tekla.Structures.DrawingAlongLineOrWithLeaderLinePlacingType

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public class AlongLineOrWithLeaderLinePlacingType : PreferredPlacingTypeBase

The AlongLineOrWithLeaderLinePlacingType type exposes the following members.

Constructors
  NameDescription
Public methodAlongLineOrWithLeaderLinePlacingType
Creates a new along line or with leader line placing type instance.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next