AABBAddition Operator (AABB, AABB)

Combines (adds) the given two axis-aligned 3d bounding boxes.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public static AABB operator +(
	AABB AABB1,
	AABB AABB2
)

Parameters

AABB1
Type: Tekla.Structures.Geometry3dAABB
The first axis-aligned 3d bounding box to combine.
AABB2
Type: Tekla.Structures.Geometry3dAABB
The second axis-aligned 3d bounding box to combine.

Return Value

Type: AABB
The new combined axis-aligned 3d bounding box.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next