DistanceListAdd Method

Adds the specified item at the end of the list.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.3
Syntax
Examples
This example shows how to add a new Distance instance at the end of the DistanceList.
using Tekla.Structures.Datatype;

public class Example
{
       public void Example1()
       {
           Distance[] distances = { new Distance(30.2), new Distance(2.3) };
           DistanceList distanceList = new DistanceList(distances);

           // New distances can be added to the list using the DistanceList.Add method.
           distanceList.Add(new Distance(2));
           distanceList.Add(new Distance(40, Distance.UnitType.Inch));
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next