Tekla.Structures Namespace

The Tekla.Structures namespace contains some basic common types that are shared between Tekla Structures Model and Drawing.
Classes
  ClassDescription
Public classAssertion
Defines an assertion by the method it failed in and the messages it provided.
Public classClashCheckOptions
The ClashCheckOptions class represents the clash check options.
Public classComponentOptions
The ComponentOptions class represents the component options.
Public classIdentifier
The Identifier class represents an identifier that holds information about the identifier number of an object.
Public classModuleManager
The ModuleManager class handles the product model module configuration information: the information that defines what configuration the customer is currently running.
Public classTeklaStructuresFiles
The TeklaStructuresFiles class is for the paths where the attributes file will be searched for.
Public classTeklaStructuresInfo
The TeklaStructuresInfo class provides information about Tekla Structures.
Public classTeklaStructuresSettings
The TeklaStructuresSettings class provides methods to inquire application settings.
Public classTeklaStructuresSettingsToolOptionNames
Tool option names.
Public classTeklaStructuresVariables
The EnvironmentVariables class contains a sorted list specializing in getting active environment variables and advanced option settings. It also checks options.ini files in the active model folder as well as options_user.ini files.
Delegates
  DelegateDescription
Public delegateTeklaStructuresSettingsInvalidPathCallback
The invalid path callback - provides error logging for GetAdvancedOptionPaths when a string is found to be invalid as a path
Enumerations
  EnumerationDescription
Public enumerationAutoDirectionTypeEnum
The auto direction type defines how a connection or detail coordinate system will be oriented automatically.
Public enumerationComponentDefinitionTypeEnum
The component definition type tells what kind of a component is in question.
Public enumerationComponentOptionsBoltEdgeDistanceReferenceEnum
The bolt edge distance reference type.
Public enumerationConnectionStatusEnum
The status type defines what the status of a connection or a detail is. In the model the color of the symbol (green, yellow, red) indicates the status.
Public enumerationDetailTypeEnum
The detail type defines what kind of a detail is in question.
Public enumerationModuleManagerProgramConfigurationEnum
The configuration information of the program.
Public enumerationPositionTypeEnum
The position type for connections and details.
Public enumerationPropertyTypeEnum
The type of property: int/double/string.
Public enumerationTeklaStructuresDatabaseTypeEnum
The object types to be used in filter expressions.
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Next