Tekla.Structural.InteropAssemblies.TeddsCalc Namespace

Tekla Tedds Calculator API

The Tedds Calculator is the application which performs the actual calculation processing, it can be used to evaluate single mathematical expressions or to evaluate complete calculations.

The Tedds Calculator is an Out-of-process COM Server TeddsCalc.exe which means it can be used from both 32-bit and 64-bit processes.

The Tekla.Structural.InteropAssemblies.TeddsCalc namespace contains the classes and types required to use the Tedds Calculator API.

Interfaces
  InterfaceDescription
Public interfaceICalculator
Interface for the main Tedds Calculator
Public interfaceICalculatorExEvents
Interface for Calculator events.
Public interfaceICalcValue
Interface for an ICalcValue, the fundamental data type used by the calculator for input and output values
Public interfaceIFunctions
Interface for executing calculation commands
Enumerations
  EnumerationDescription
Public enumerationCalcErrorType
Error types
Public enumerationCalcProgressEvent
Progress bar modes
Public enumerationCalcStatus
Calculate status codes. Values less than zero are considered failures, values greater than zero are considered successful.
Public enumerationCalcValueFormat
Formats for converting numeric values to a string
Public enumerationCalcValueType
Value data types
Public enumerationOutputFormat
Document output formats
Public enumerationVariableFormat
Data formats for variables, currently only XML format is supported
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next