ITeddsDocument Interface

Interface for an open Document

Namespace:  Tekla.Structural.InteropAssemblies.Tedds
Assembly:  Tedds.TeddsIA (in Tedds.TeddsIA.dll) Version: 25.0.0.0
Syntax
public interface ITeddsDocument

The ITeddsDocument type exposes the following members.

Properties
  NameDescription
Public propertyBimObjectId
Returns a BIM object identifier associated with the document
Public propertyCalcItem
Returns a CalcItem object which represents the calculation associated with the document
Public propertyFullName
Returns the document full path and file name
Public propertyName
Returns the documents name (excluding file extension)
Public propertyPath
Return documents file path (excluding file name)
Public propertySaved
Saved status of document
Public propertyVariablesXml
Variables defined in the document in the Tedds XML schema format
Top
Methods
  NameDescription
Public methodActivate
Activate this document
Public methodCalculate
Calculate document
Public methodCalculate2
Calculate the document and return the calculation status code
Public methodClose
Close the document
Public methodSave
Save changes to the document
Public methodSaveAs
Save document to a new file location
Public methodSaveAsPdf
Save the document in Adobe PDF format
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next