ICalculator Interface

Interface for the main Tedds Calculator

Namespace:  Tekla.Structural.InteropAssemblies.TeddsCalc
Assembly:  Tedds.TeddsCalcIA (in Tedds.TeddsCalcIA.dll) Version: 25.0.0.0
Syntax
public interface ICalculator

The ICalculator type exposes the following members.

Properties
  NameDescription
Public propertyCalculatingErrorEvents
Determines whether error events are fired to the event listeners
Public propertyCalculatingProgressEvents
Determines whether progress events are fired to the event listeners
Public propertyFunctions
Returns an object supporting the IFunctions interface which is used to access the internal Tedds calculator functions
Public propertyStatus
Returns the status of the Tedds calculator when the last evaluation finished.
Public propertyUndefinedVariableEvents
Determines whether undefined variable events are fired to the event listeners
Public propertyVersionLibraryMajor
Returns the major version number of the Tedds Engineering Library
Public propertyVersionLibraryMinor
Returns the minor version number of the Tedds Engineering Library
Public propertyVersionMajor
Returns the major version number of the Tedds software
Public propertyVersionMinor
Returns the minor version number of the Tedds software
Public propertyWindowHandle
Returns the Tedds calculator's main window handle
Top
Methods
  NameDescription
Public methodCopyOutputToClipboard
Copies the output item to the Windows clipboard in the specified format
Public methodGetOutput
Returns the documented output from the calculator in the specified format.
Public methodGetVariables
Returns all the variables defined in the calculator excluding temporary variables
Public methodGetVariables2
Returns the current Document and Calc Section variables in the specified data format
Public methodInitialize
Initializes the calculator to start calculating
Public methodInitializeCalc
Initializes the calculator and starts calculating using the specified Calc Library Item
Public methodSetForegroundWindow
Executes the Windows API function SetForegroundWindow from the Tedds calculator process.
Public methodSetOwnerWindow
Sets which window owns the Tedds calculator's main window
Public methodSetVariables
Assign the specified variables to the calculator instance
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next