ITeddsDocuments Interface

Interface for a collection of open documents

Namespace:  Tekla.Structural.InteropAssemblies.Tedds
Assembly:  Tedds.TeddsIA (in Tedds.TeddsIA.dll) Version: 25.0.0.0
Syntax
public interface ITeddsDocuments : IEnumerable

The ITeddsDocuments type exposes the following members.

Properties
  NameDescription
Public propertyCount
Returns the number of documents in the collection
Public propertyItem
Returns a single document in the collection
Top
Methods
  NameDescription
Public methodAdd
Add a new document
Public methodAdd2
Add a new document using the specified Calc Item and input variables
Public methodAdd3
Add a new document using the specified Calc Item, input variables and pre-calculated RTF
Public methodClose
Close all documents
Public methodGetEnumerator
Enumeration interface for iterating the items in the collection
Public methodOpen
Open an existing document
Public methodSave
Saved changes to all open documents
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next