ICalculatorExEventsCalculatingProgress Method

Calculating progress event

Namespace:  Tekla.Structural.InteropAssemblies.TeddsCalc
Assembly:  Tedds.TeddsCalcIA (in Tedds.TeddsCalcIA.dll) Version: 25.0.0.0
Syntax
void CalculatingProgress(
	CalcProgressEvent progressEvent,
	uint progressValue,
	string text,
	out CalcStatus status
)

Parameters

progressEvent
Type: Tekla.Structural.InteropAssemblies.TeddsCalcCalcProgressEvent
Progress event type
progressValue
Type: SystemUInt32
Progress value for the current event
text
Type: SystemString
Text for the current event
status
Type: Tekla.Structural.InteropAssemblies.TeddsCalcCalcStatus
Calculation status after the event has been processed, the caller can change the state to stop the calculation process
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next