IProjectFileItem Interface

Interface for a project file item

Namespace:  Tekla.Structural.InteropAssemblies.Tedds
Assembly:  Tedds.TeddsIA (in Tedds.TeddsIA.dll) Version: 25.0.0.0
Syntax
public interface IProjectFileItem

The IProjectFileItem type exposes the following members.

Properties
  NameDescription
Public propertyFullName
Returns the full path and file name of the referenced file
Public propertyIsFolder
Returns whether the object is a folder
Public propertyName
File name (excluding file extension)
Public propertyParentFolder
Parent folder in the project hierarchy
Public propertyPath
Returns the path of the referenced file
Top
Methods
  NameDescription
Public methodOpen
Open the referenced file and return the ITeddsDocument interface
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next