DistanceUseUnitsInDecimalString Property

Gets or sets a boolean value indicating whether to use units in the decimal string representation.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.3
Syntax
public static bool UseUnitsInDecimalString { get; set; }

Property Value

Type: Boolean
Indicates whether to use units in the decimal string representation.
Examples
This example shows how to use the UseUnitsInDecimalString property.
using Tekla.Structures.Datatype;
using System.Globalization;

public class Example
{
       public void Example1()
       {
           // UseUnitsInDecimalString controls whether the unit type is shown in the decimal string representation.
           Distance.UseUnitsInDecimalString = true;

           // For this demonstration, we'll format 300.2 millimeters.
           Distance distance = new Distance(300.2);
           string formattedString = distance.ToDecimalString("0.00", CultureInfo.InvariantCulture);
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next