ArcArcAttributes Class

The ArcAttributes class is the attributes class for the arc.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class ArcAttributes : OpenGraphicObjectOpenGraphicObjectAttributes

The ArcArcAttributes type exposes the following members.

Constructors
  NameDescription
Public methodArcArcAttributes
Creates a new default arc attributes instance that loads standard attributes.
Public methodArcArcAttributes(String)
Creates a new arc attributes instance that loads the specified attributes.
Top
Properties
  NameDescription
Public propertyArrowhead
The arrowhead attributes of the open graphic object. The end points of an open graphic object can contain arrowheads.
(Inherited from OpenGraphicObjectOpenGraphicObjectAttributes.)
Public propertyLine
The line attributes of the graphic object. A graphic object always consists of lines.
(Inherited from GraphicObjectGraphicObjectAttributes.)
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next