BentPlateGeometrySolverAddLeg Method (ConnectiveGeometry, LineSegment, Contour, LineSegment)

Appends a polygon section to this ConnectiveGeometry, using the specified connection points and maximal radius for the cylindrical connection.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public ConnectiveGeometry AddLeg(
	ConnectiveGeometry geometry,
	LineSegment segment1,
	Contour polygon,
	LineSegment segment2
)

Parameters

geometry
Type: Tekla.Structures.ModelConnectiveGeometry
ConnectiveGeometry used to create a connection with.
segment1
Type: Tekla.Structures.Geometry3dLineSegment
the two connection points on this instance geometry
polygon
Type: Tekla.Structures.ModelContour
the polygonal contour to add to this geometry
segment2
Type: Tekla.Structures.Geometry3dLineSegment
the two connection points on polygon geometry

Return Value

Type: ConnectiveGeometry
Modified ConnectiveGeometry if command succeeded or geometry otherwise.
Exceptions
ExceptionCondition
ConnectiveGeometryExceptionThrown if could not create or modify ConnectiveGeometry instance.
ArgumentExceptionThrown when geometry is a stand-alone bend geometry, meaning that the first GeometrySection is a BendSurfaceNode.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next