AnalysisArea Class

The AnalysisArea class contains information related to analysis areas.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisArea : AnalysisObject

The AnalysisArea type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisArea
Initializes a new instance of the AnalysisArea class.
Top
Properties
  NameDescription
Public propertyAnalysisDesignCode
Gets or sets the design code of the analysis area.
Public propertyAnalysisType
Gets or sets the analysis type of the analysis area.
Public propertyArea
Gets or sets the area polygon of the analysis area.
Public propertyAreaHoles
Gets or sets the area holes of the analysis area.
Public propertyInnerPositions
Gets or sets the inner positions of the analysis area.
Public propertyLabel
Gets or sets the label of the analysis area.
Public propertyMaterial
Gets or sets the material of the analysis area.
Public propertyProfile
Gets or sets the profile of the analysis area.
Public propertyRigidDiaphragm
Gets or sets the rigid diaphragm of the analysis area.
Public propertyThickness
Gets or sets the thickness of the analysis area.
Top
Methods
  NameDescription
Public methodDelete
Deletes an analysis area. Method is not implemented yet.
Public methodGetAreaHoles
Gets the area holes of the analysis area.
Public methodGetInnerPositions
Gets the inner positions of the analysis area.
Public methodModify
Modifies an analysis area. Method is not implemented yet.
Public methodSelect
Selects an analysis area. The AnalysisModelName and ID have to be set.
(Overrides AnalysisObjectSelect.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next