GeometrySectionEnumerator Class

The GeometrySectionEnumerator class is used to enumerate the geometry sections of a bent plate geometry.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelGeometrySectionEnumerator

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public sealed class GeometrySectionEnumerator : IEnumerator

The GeometrySectionEnumerator type exposes the following members.

Properties
  NameDescription
Public propertyCurrent
Gets the current geometry section.
Top
Methods
  NameDescription
Public methodMoveNext
Moves to the next item in the enumerator.
Public methodReset
Resets the enumerator to the beginning.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next