Tekla.Structures.Dialog.UIControls Namespace

The Tekla.Structures.Dialog.UIControls namespace contains dialog templates and custom controls.
Classes
  ClassDescription
Public classBindableRadioButton
The BindableRadioButton class represents a RadioButton control that can be bound to the dialog attributes file. Use "Checked" as the BindPropertyName and "Integer" as the AttributeTypeName.
Public classBoltCatalogSize
The BoltCatalogSize class represents a control to select the bolt size using the bolt catalog.

Bolt catalog controls always need to be in pairs, meaning in every dialog there has to be a BoltCatalogStandard and a BoltCatalogSize control.

The property BoltCatalogStandard.LinkedBoltCatalogSize sets to which BoltCatalogSize the control is linked.

Public classBoltCatalogStandard
The BoltCatalogStandard class represents a control to select the bolt standard using the bolt catalog.

Bolt catalog controls always need to be in pairs, meaning in every dialog there has to be a BoltCatalogStandard and a BoltCatalogSize control.

The property BoltCatalogStandard.LinkedBoltCatalogSize sets to which BoltCatalogSize the control is linked.

Public classCommitAction
The CommitAction class represents a "template" dialog for commit actions.
Public classComponentCatalog
The ComponentCatalog class represents a group of controls to select components using the component catalog.
Public classCreateApplyCancel
The CreateApplyCancel class represents a control including the Create-Apply-Cancel button group.
Public classCreateDialog
The CreateDialog class represents a "template" dialog for creating something from parts.
Public classCustomObservableCollectionT
CustomObservableCollection for synchronizing UI controls.
Public classDataGrid
The DataGrid class represents a data grid control that can contain images.
Public classEnvironmentFiles
The EnvironmentFiles class is for the paths where the attributes file will be searched for.
Public classEnvironmentVariables
The EnvironmentVariables class contains a sorted list specializing in getting active environment variables and advanced option settings. It also checks options.ini files in the active model folder as well as options_user.ini files.
Public classImageComboBox Obsolete.
The ImageComboBox class represents a combo box control that can contain images.
Public classImageItem
The ImageItem class defines the images that will be contained in the image combo box.
Public classImageList
The ImageList class contains a list of ImageItems.
Public classImageListComboBox
The ImageListComboBox class represents a combo box control that can contain images from an ImageList control.
Public classLoadingForm
The LoadingForm class creates a dialog that is shown while something is being loaded by the main window and that needs the process to finish.
Public classLocalizeForm
The LocalizeForm class is for localizing the forms.
Public classMaterialCatalog
The MaterialCatalog class represents a group of controls to select materials using the material catalog.
Public classMaterialSelectionForm
The MaterialSelectionForm class represents a dialog to select materials using the material catalogs.
Public classMeshCatalog
The MeshCatalog class represents a group of controls to select meshes using the mesh catalogs.
Public classMeshSelectionForm
The MeshSelectionForm class represents a dialog to select meshes using the mesh catalog.
Public classModelAccess
The ModelAccess class contains helper methods for connecting to and accessing the model and objects in the model. The class attempts to provide efficient but robust methods for connecting to and verifying the connection to the model.
Public classOkApplyCancel
The OkApplyCancel class represents a control including the Ok-Apply-Cancel button group.
Public classOkApplyModifyGetOnOffCancel
The OkApplyModifyGetOnOffCancel class represents a control including the Ok-Apply-Modify-Get-On/Off-Cancel button group.
Public classOkCancel
The OkCancel class represents a control including the Ok-Cancel button group.
Public classOrganizerDialog
The OrganizerDialog class represents a "template" of an organizer dialog.
Public classProfileCatalog
The ProfileCatalog class represents a group of controls to select profiles using the profile catalogs.
Public classProfileSelectionForm
The ProfileSelectionForm class represents a dialog to select profiles using the profile catalogs.
Public classPropertiesDialog
The PropertiesDialog class represents a "template" of a properties dialog.
Public classReinforcementCatalog
The ReinforcementCatalog class represents a group of controls to select rebars using the rebar catalogs.
Public classReinforcementSelectionForm
The ReinforcementSelectionForm class represents a dialog to select rebars using the rebar catalogs.
Public classSaveLoad
The SaveLoad class represents a save-load-save as group of controls including the functionality.
Public classShapeCatalog
The ShapeCatalog class represents a group of controls to select Shapes using the Shape catalog.
Public classShapeSelectionForm
The ShapeSelectionForm class represents a dialog to select Shapes using the Shape catalogs.
Public classTree
The Tree class represents a tree view control that can contain images.
Public classTreeViewDialog
The TreeViewDialog class represents a "template" of a tree view dialog.
Public classWpfBoltCatalogSize
The WPFBoltCatalogSize class represents a control to select the bolt size using the bolt catalog.

Bolt catalog controls always need to be in pairs, meaning in every dialog there has to be a WpfBoltCatalogStandard and a WpfBoltCatalogSize control.

Public classWpfBoltCatalogStandard
The WpfBoltCatalogStandard class represents a control to select the bolt standard using the bolt catalog.

Bolt catalog controls always need to be in pairs, meaning in every dialog there has to be a WpfBoltCatalogStandard and a WpfBoltCatalogSize control.

Public classWpfComponentCatalog
The WpfComponentCatalog class represents a group of controls to select components using the component catalog.
Public classWpfCreateApplyCancel
Interaction logic for WPFCreateAppyCancel.xaml. Control is meant to be used with non-dependent plug-ins
Public classWpfFilterCheckBox
The WpfFilterAttribute class represents a checkbox control for enabling/disabling dialog attributes defined with StructuresFieldAttribute.
Public classWpfMaterialCatalog
The WpfMaterialCatalog class represents a group of controls to select materials using the material catalog.
Public classWpfMeshCatalog
The WpfMeshCatalog class represents a group of controls to select meshes using the mesh catalog.
Public classWpfOkApplyModifyGetOnOffCancel
Interaction logic for WpfOkApplyModifyGetOnOffCancel.xaml
Public classWpfOkCreateCancel
Interaction logic for WPFOkCreateCancel.xaml
Public classWpfProfileCatalog
The WpfProfileCatalog class represents a group of controls to select profiles using the profile catalog.
Public classWpfReinforcementCatalog
The WpfReinforcementCatalog class represents a group of controls to select rebars using the reinforcement catalog.
Public classWpfSaveLoad
Interaction logic for WpfSaveload.xaml
Public classWpfShapeCatalog
The WpfShapeCatalog class represents a group of controls to select shapes using the shape catalog.
Enumerations
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next