TeklaStructuresDatabaseTypeEnum Enumeration

The object types to be used in filter expressions.

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public enum TeklaStructuresDatabaseTypeEnum
Members
  Member nameValueDescription
UNKNOWN0 The unknown type.
POINT1 The point type, this is not a ModelObject.
PART2 The part type.
CONNECTION3 The connection type, used for details and seams as well.
COMPONENT4 The component type, used for macros, plug-ins and custom parts.
GRID7 The grid type.
FITTING9 The fitting type.
BOLT10 The bolt type.
PART_CUT11 The part cut type.
PLANE_CUT12 The plane cut type.
WELDING13 The welding type.
ASSEMBLY15 The assembly type.
CONSTRUCTION_LINE24 The construction line type, this is not a ModelObject.
PLANE30 The plane type, used for control planes and grid planes.
DRAWING34The drawing.
DB_CONNECTION35The connection type.
PART_ADD38 The part add type.
WELD_CUT39 The weld preparation.
CONSTRUCTION_CIRCLE42 The construction circle type, this is not a ModelObject.
CONSTRUCTION_ARC43The construction arc
DB_COMPONENT46 The component type.
REBAR47 The rebar type, used for single rebars, groups, meshes and strands.
FOREIGN_OBJECT48The foreign object.
LOAD_LOAD49 The load type.
LOAD_POINT50 The load point type.
LOAD_LINE51 The load line type.
LOAD_AREA52 The load area type.
LOAD_UNIFORM53 The load uniform type.
LOAD_GROUP54 The load group type.
LOAD_TEMPERATURELOAD72 The temperature load type.
SURFACE_TREATMENT73 The surface treatment type.
REBAR_SPLICE74 The rebar splice type.
ANALYSIS_MODEL75The analysis model.
ANALYSIS_PART76The analysis part.
ANALYSIS_NODE77The analysis node.
EDGE_CHAMFER79 The edge chamfer type.
TASK80 The task type.
TASK_DEPENDENCY81 The task dependency type.
TASK_WORKTYPE83 The task worktype type.
HIERARCHIC_DEFINITION84 The hierarchic definition type.
HIERARCHIC_OBJECT85 The hierarchic object type.
DB_POUR_BREAK89 The pour break type.
DB_POUR_OBJECT90 The pour object type.
REBARSET_ADDITION95The rebar set addition type.
REBARSET_MODIFIER96The rebar set modifier type.
SURFACE_OBJECT97The surface object type
BENT_PLATE98The bent plate type
HELIX99The helix type
DB_POUR_UNIT101 The pour unit type
CONSTRUCTION_POLYCURVE103The construction polycurve
STOREY104Building Hierarchy Storey
BUILDING_SITE105Building Hierarchy Building
BUILDING106Building Hierarchy Site
SPACE108Building Hierarchy Space
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next