LeaderLine Class

The LeaderLine class defines a leader line attached to a parent object, for example a Text or a Mark. The LeaderLine can be modified to add/remove elbow points or to change where it is pointing.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class LeaderLine : DrawingObject

The LeaderLine type exposes the following members.

Properties
  NameDescription
Public propertyElbowPoints
The leader line's elbow points (middle points).
Public propertyEndPoint
The end point of the leader line (set by the parent object).
Public propertyLeaderLineType
Gets the type of the leader line. For a list of the available leader line types see LeaderLineLeaderLineTypes.
Public propertyStartPoint
The starting point of the leader line.
Top
Methods
  NameDescription
Public methodDelete
A leader line cannot be deleted.
(Overrides DatabaseObjectDelete.)
Public methodInsert
A leader line cannot be inserted.
(Overrides DatabaseObjectInsert.)
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides DrawingObjectIsEqual(Object).)
Public methodModify
Modifies the leader line in the current drawing database.
(Overrides DatabaseObjectModify.)
Public methodSelect
Selects the leader line from the current drawing database.
(Overrides DatabaseObjectSelect.)
Top
Examples
using Tekla.Structures.Drawing;
using Point = Tekla.Structures.Geometry3d.Point;

public class Example
{
    public void Example1()
    {
        DrawingHandler DrawHandler = new DrawingHandler();
        Drawing CurrentDrawing = DrawHandler.GetActiveDrawing();
        ContainerView Sheet = CurrentDrawing.GetSheet();
        DrawingObjectEnumerator AllViews = Sheet.GetViews();
        while(AllViews.MoveNext())
        {
            if(AllViews.Current is View)
            {
                View CurrentView = (View)AllViews.Current;

                Point MyInsertionPoint = new Point(200, 600);
                Text.TextAttributes MyTextAttributes = new Text.TextAttributes();

                // Here we create one Text with a LeaderLine attached to it.
                MyTextAttributes.PreferredPlacing = PreferredTextPlacingTypes.LeaderLinePlacingType();
                Text MyText = new Text(CurrentView, MyInsertionPoint, "Text with a LeaderLine.",
                                       new LeaderLinePlacing(new Point(10, 10)), MyTextAttributes);
                MyText.Insert();

                // Next we enumerate through all its children, which in this case is the LeaderLine.
                DrawingObjectEnumerator TextChildren = MyText.GetObjects();
                while(TextChildren.MoveNext())
                {
                    if(TextChildren.Current is LeaderLine)
                    {
                        // We then modify the LeaderLine to contain some elbow points of our choosing.
                        LeaderLine CurrentLeaderLine = (LeaderLine)TextChildren.Current;
                        CurrentLeaderLine.ElbowPoints.Add(new Point(50, 250));
                        CurrentLeaderLine.ElbowPoints.Add(new Point(150, 250));
                        CurrentLeaderLine.Modify();
                        CurrentLeaderLine.Delete();
                    }
                }
            }
            else
            {
                AllViews = ((ContainerView)AllViews.Current).GetViews();
            }
        }
    }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next