MeshItemEnumerator Class

The MeshItemEnumerator class allows to loop through the catalog mesh items.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.CatalogsMeshItemEnumerator

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class MeshItemEnumerator : IEnumerator

The MeshItemEnumerator type exposes the following members.

Properties
  NameDescription
Public propertyCurrent
Returns a mesh item instance of the current element.
Top
Methods
  NameDescription
Public methodGetSize
Returns the total amout of items.
Public methodMoveNext
Moves to the next item in the enumerator.
Public methodReset
Resets the enumerator to the beginning.
Public methodStatic memberSelectMeshItem
Selects a mesh item in the mesh database with the given name and grade.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next