DrawingUpToDateStatus Enumeration

The drawing up to date status.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public enum DrawingUpToDateStatus
Members
  Member nameValueDescription
DrawingIsUpToDate1 The drawing is up to date.
PartsWereModified2 Some parts in the drawing were modified since the last update.
DrawingIsUpToDateButMayNeedChecking4 The drawing is up to date but may need checking.
IncludedDrawingModified5 The included drawing was modified.
OriginalPartDeleted6 The original part from which the drawing was created was deleted since the last update.
AllPartsDeleted7 All parts were deleted.
NumberOfPartsInNumberingSeriesIncreased8 The number of parts in the numbering series has increased since the last update.
NumberOfPartsInNumberingSeriesDecreased9 The number of parts in the numbering series has decreased since the last update.
DrawingWasCloned10 The drawing was cloned from another drawing.
DrawingWasUpdated11 The drawing was updated.
CopiedViewChanged12 The copied view changed.
DrawingWasSplitted13 The drawing was splitted (cloned) during numbering.
MovedViewDeleted14 The moved view was deleted.
MovedViewLabelChanged15 The moved view symbol has changed.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next