AnalysisPosition Class

The AnalysisPosition class contains information related to analysis positions.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Analysis
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public sealed class AnalysisPosition : AnalysisObject

The AnalysisPosition type exposes the following members.

Constructors
  NameDescription
Public methodAnalysisPosition
Initializes a new instance of the AnalysisPosition class
Top
Properties
  NameDescription
Public propertyAnalysisModelName
Gets or sets the analysis model name.
(Inherited from AnalysisObject.)
Public propertyAnalysisObjectType
Gets or sets the type of the analysis object.
(Inherited from AnalysisObject.)
Public propertyFatherObject2ID
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.)
Public propertyFatherObject2Type
Gets or sets the type of the father object.
(Inherited from AnalysisObject.)
Public propertyFatherObjectID
Gets or sets the identifier of the father part.
(Inherited from AnalysisObject.)
Public propertyFatherObjectType
Gets or sets the type of the father object.
(Inherited from AnalysisObject.)
Public propertyID
Gets or sets the identifier of the analysis object.
(Inherited from AnalysisObject.)
Public propertyNode
The node of the position.
Public propertyType
The type of the position.
Top
Methods
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next