RebarSet Class

The RebarSet class represents a set of reinforcing bars.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class RebarSet : ModelObject, 
	IAssemblable

The RebarSet type exposes the following members.

Constructors
  NameDescription
Public methodRebarSet
Initializes a new instance of the RebarSet class.
Top
Properties
  NameDescription
Public propertyBarOrientation
Gets or sets the bar orientation line. If this is non-null, then it is used to orient the bar planes such that the line is parallel to all the planes.
Public propertyFatherPart
Gets or sets the father part for the rebar set bars. If set, overrides the automatic bar parenting.
Public propertyGuidelines
Gets or sets the rebar set's guidelines.
Public propertyLayerOrderNumber
Gets or sets the layer order number. If set to 0 this means use the creation date/time of the rebar set object to determine the layering.
Public propertyLegFaces
Gets or sets the rebar set's leg faces.
Public propertyRebarProperties
Gets or sets the reinforcing bar properties for the rebar set.
Top
Methods
  NameDescription
Public methodDelete
Deletes the rebar set instance with the given identifier from the model database.
(Overrides ModelObjectDelete.)
Public methodGetAssembly
Returns the assembly that the rebar set belongs to.
Public methodGetRebarLegSurfaces
Returns an enumerator of all child RebarLegSurfaceObject objects.
Public methodGetRebarModifiers
Returns an enumerator of all child BaseRebarModifier objects.
Public methodGetRebarSetAdditions
Returns an enumerator of all child RebarSetAddition objects.
Public methodGetReinforcements
Returns an enumerator of all the connected SingleRebar objects.
Public methodInsert
Inserts the rebar set into the model database.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the rebar set in the model database to match the current one.
(Overrides ModelObjectModify.)
Public methodSelect
Selects the rebar set from the model database. The rebar set identifier must be set.
(Overrides ModelObjectSelect.)
Top
Examples
The following example shows how to create a rebarset.
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
            // Create rebarset
            var rebarSet = new RebarSet();
            rebarSet.RebarProperties.Name = "RebarSet Test";
            rebarSet.RebarProperties.Grade = "The Grade";
            rebarSet.RebarProperties.BendingRadius = 42.0;
            rebarSet.RebarProperties.Class = 7;
            rebarSet.RebarProperties.Size = "16";
            rebarSet.LayerOrderNumber = 17;

            // Create leg face 1
            var legFace1 = new RebarLegFace
            {
                LayerOrderNumber = 2,
                AdditonalOffset = 25.0,
                Reversed = false
             };

            legFace1.Contour.AddContourPoint(new ContourPoint(new Point(0, 0, 0), null));
            legFace1.Contour.AddContourPoint(new ContourPoint(new Point(800, 0, 0), null));
            legFace1.Contour.AddContourPoint(new ContourPoint(new Point(800, 1200, 0), null));
            legFace1.Contour.AddContourPoint(new ContourPoint(new Point(0, 1200, 0), null));

            // Add leg face 1
            rebarSet.LegFaces.Add(legFace1);

            // Create leg face 2
            var legFace2 = new RebarLegFace
            {
                LayerOrderNumber = 2,
                AdditonalOffset = 25.0,
                Reversed = false
            };

            legFace2.Contour.AddContourPoint(new ContourPoint(new Point(0, 0, 0), null));
            legFace2.Contour.AddContourPoint(new ContourPoint(new Point(0, 0, 500), null));
            legFace2.Contour.AddContourPoint(new ContourPoint(new Point(0, 1200, 500), null));
            legFace2.Contour.AddContourPoint(new ContourPoint(new Point(0, 1200, 0), null));

            //  Add leg face 2
            rebarSet.LegFaces.Add(legFace2);

            // Create the guideline
            var guideline = new RebarGuideline();
            guideline.Spacing = RebarSpacing.Create(
                RebarSpacing.SpacingType.EXACT_FLEXIBLE_LAST,
                new RebarSpacing.Offset(true, 0.0),
                new RebarSpacing.Offset(true, 0.0),
                200.0);

            guideline.Curve.AddContourPoint(new ContourPoint(new Point(0.0, 0.0, 0.0), null));            
            guideline.Curve.AddContourPoint(new ContourPoint(new Point(0.0, 1200, 0.0), null));

            rebarSet.Guidelines.Add(guideline);
            rebarSet.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next