RebarSet Class

The RebarSet class represents a set of reinforcing bars.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class RebarSet : ModelObject, 
	IAssemblable

The RebarSet type exposes the following members.

Constructors
  NameDescription
Public methodRebarSet
Initializes a new instance of the RebarSet class.
Top
Properties
  NameDescription
Public propertyBarOrientation
Gets or sets the bar orientation line. If this is non-null, then it is used to orient the bar planes such that the line is parallel to all the planes.
Public propertyFatherPart
Gets or sets the father part for the rebar set bars. If set, overrides the automatic bar parenting.
Public propertyGuidelines
Gets or sets the rebar set's guidelines.
Public propertyIdentifier
The identifier of the object.
(Inherited from Object.)
Public propertyIsUpToDate
Gets if the object does not have a modification which is not shared.
(Inherited from ModelObject.)
Public propertyLayerOrderNumber
Gets or sets the layer order number. If set to 0 this means use the creation date/time of the rebar set object to determine the layering.
Public propertyLegFaces
Gets or sets the rebar set's leg faces.
Public propertyModificationTime
Gets latest time of the object was modified or created.
(Inherited from ModelObject.)
Public propertyRebarProperties
Gets or sets the reinforcing bar properties for the rebar set.
Top
Methods
  NameDescription
Public methodCompareTo
Compares Identifiers of model objects.
(Inherited from ModelObject.)
Public methodDelete
Deletes the rebar set instance with the given identifier from the model database.
(Overrides ModelObjectDelete.)
Public methodEquals
Check if Identifiers of model objects are same.
(Inherited from ModelObject.)
Public methodCode exampleGetAllReportProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAllUserProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAssembly
Returns the assembly that the rebar set belongs to.
Public methodGetChildren
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.)
Public methodGetCoordinateSystem
Returns the coordinate system for the given model object.
(Inherited from ModelObject.)
Public methodGetDoubleReportProperties
Retrieves multiple double report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetDoubleUserProperties
Retrieves all double properties for the model object.
(Inherited from ModelObject.)
Public methodGetDynamicStringProperty
Gets a dynamic string property from the model object.
(Inherited from ModelObject.)
Public methodGetFatherComponent
Returns the father component of the model object.
(Inherited from ModelObject.)
Public methodGetHierarchicObjects
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.)
Public methodGetIntegerReportProperties
Retrieves multiple integer report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetIntegerUserProperties
Retrieves all integer properties for the model object.
(Inherited from ModelObject.)
Public methodGetPhase
Retrieves the phase of the model object (the phase number, the phase name, the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.)
Public methodGetRebarLegSurfaces
Returns an enumerator of all child RebarLegSurfaceObject objects.
Public methodGetRebarModifiers
Returns an enumerator of all child BaseRebarModifier objects.
Public methodGetRebarSetAdditions
Returns an enumerator of all child RebarSetAddition objects.
Public methodGetReinforcements
Returns an enumerator of all the connected SingleRebar objects.
Public methodGetReportProperty(String, Double)
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Int32)
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, String)
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetStringReportProperties
Retrieves multiple string report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetStringUserProperties
Retrieves all string properties for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Double)
Retrieves a double property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Int32)
Retrieves an integer property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, String)
Retrieves a string property for the model object.
(Inherited from ModelObject.)
Public methodInsert
Inserts the rebar set into the model database.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the rebar set in the model database to match the current one.
(Overrides ModelObjectModify.)
Public methodSelect
Selects the rebar set from the model database. The rebar set identifier must be set.
(Overrides ModelObjectSelect.)
Public methodSetDynamicStringProperty
Sets a dynamic string property for the model object.
(Inherited from ModelObject.)
Public methodSetLabel
Sets a label for an object when a new instance is created, this method must be called before Insert. The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.)
Public methodSetPhase
Sets the phase of the model object.
(Inherited from ModelObject.)
Public methodSetUserProperties
Sets multiple properties for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the model object.
(Inherited from ModelObject.)
Top
Examples
The following example shows how to create a rebarset.
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
            // Create rebarset
            var rebarSet = new RebarSet();
            rebarSet.RebarProperties.Name = "RebarSet Test";
            rebarSet.RebarProperties.Grade = "The Grade";
            rebarSet.RebarProperties.BendingRadius = 42.0;
            rebarSet.RebarProperties.Class = 7;
            rebarSet.RebarProperties.Size = "16";
            rebarSet.LayerOrderNumber = 17;

            // Create leg face 1
            var legFace1 = new RebarLegFace
            {
                LayerOrderNumber = 2,
                AdditonalOffset = 25.0,
                Reversed = false
             };

            legFace1.Contour.AddContourPoint(new ContourPoint(new Point(0, 0, 0), null));
            legFace1.Contour.AddContourPoint(new ContourPoint(new Point(800, 0, 0), null));
            legFace1.Contour.AddContourPoint(new ContourPoint(new Point(800, 1200, 0), null));
            legFace1.Contour.AddContourPoint(new ContourPoint(new Point(0, 1200, 0), null));

            // Add leg face 1
            rebarSet.LegFaces.Add(legFace1);

            // Create leg face 2
            var legFace2 = new RebarLegFace
            {
                LayerOrderNumber = 2,
                AdditonalOffset = 25.0,
                Reversed = false
            };

            legFace2.Contour.AddContourPoint(new ContourPoint(new Point(0, 0, 0), null));
            legFace2.Contour.AddContourPoint(new ContourPoint(new Point(0, 0, 500), null));
            legFace2.Contour.AddContourPoint(new ContourPoint(new Point(0, 1200, 500), null));
            legFace2.Contour.AddContourPoint(new ContourPoint(new Point(0, 1200, 0), null));

            //  Add leg face 2
            rebarSet.LegFaces.Add(legFace2);

            // Create the guideline
            var guideline = new RebarGuideline();
            guideline.Spacing = RebarSpacing.Create(
                RebarSpacing.SpacingType.EXACT_FLEXIBLE_LAST,
                new RebarSpacing.Offset(true, 0.0),
                new RebarSpacing.Offset(true, 0.0),
                200.0);

            guideline.Curve.AddContourPoint(new ContourPoint(new Point(0.0, 0.0, 0.0), null));            
            guideline.Curve.AddContourPoint(new ContourPoint(new Point(0.0, 1200, 0.0), null));

            rebarSet.Guidelines.Add(guideline);
            rebarSet.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next