OperationDisplayReport Method

Opens and displays a report with the given name.

If a path is not given in the filename, the file is searched from the folder defined with the advanced option XS_REPORT_OUTPUT_DIRECTORY.

See Tekla Structures Help for more information about reports.

Namespace:  Tekla.Structures.Model.Operations
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public static bool DisplayReport(
	string FileName
)

Parameters

FileName
Type: SystemString
The name of the report to display. The name must contain more than three characters.

Return Value

Type: Boolean
True if the report existed.
Exceptions
ExceptionCondition
ArgumentExceptionThrown when the file specified in the FileName is not found or when the FileName is too short.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next