Frame Class

The Frame class defines a frame that can be given to objects, including texts. A frame is a box around the object. You can specify the color and shape of the box.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DrawingFrame

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class Frame : IAxisAlignedBoundingBox, 
	IObjectAlignedBoundingBox, IIsEqual, ICloneable

The Frame type exposes the following members.

Constructors
  NameDescription
Public methodFrame
Creates a new frame instance with the specified frame type and color.
Top
Properties
  NameDescription
Public propertyColor
The frame's color.
Public propertyType
The frame's type (square, round, dashed...).
Top
Methods
  NameDescription
Public methodClone
Clones the object.
Public methodGetAxisAlignedBoundingBox
Returns the bounding box of the frame in the global axis coordinate system.
Public methodGetObjectAlignedBoundingBox
Returns the bounding box of the frame in the local coordinate system.
Public methodIsEqual
Compares the current object with an object of the same type.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next